Normal Operations
Degraded Operations
Partial Outage
Outage
Under Maintenance

Platform Slowness – We're Working on It

Incident Report for Sprinklr

Resolved

The earlier slowness on the platform has now been resolved. Our technical team identified the issue and implemented a fix, and performance has returned to normal.

Thank you for your patience and understanding while we worked through this. If you continue to experience any issues, please don’t hesitate to reach out.
Posted May 12, 2025 - 11:35 UTC

Investigating

We're currently experiencing some slowness on the platform, which may or may not be affecting load times and general performance for some users.

Our technical team is actively investigating the issue and working to resolve it as quickly as possible. We'll share updates as soon as we have more information.

Thanks for your patience and understanding.
Posted May 12, 2025 - 10:59 UTC
This incident affected: Other Social Channels (EMEA (Prod3)).